../../../../_images/image710.png

Modul 9: Membuat Layer Vektor Baru

Tujuan Pembelajaran

  • Menambah layer raster untuk dijitasi

  • Membuat fitur vektor baru (polygon, garis, dan titik)

  • Digitalisasi layer vektor baru dengan menggambar di atas layer raster dan mempertimbangkan topologi

  • Melakukan Georeferensi

Membuat peta menggunakan data yang sudah ada hanyalah permulaan. Kita telah mempelajari bagaimana mengedit dan menambahkan suatu objek ke OpenStreetMap menggunakan JOSM. Pada modul ini, kita akan mendiskusikan bagaimana mengedit layer vektor yang sudah ada pada QGIS, dan bagaimana membuat dataset baru.

1. The layer creation dialog

Sebelum Anda menambahkan data vektor baru, Anda perlu dataset (layer) vektor untuk menambahkannya. Dalam hal ini, kita akan memulai dengan membuat layer data baru, dan kemudian kita akan menambah fiturnya. Pertama, kita harus mendefinisikan dataset kita.

  1. Membuat proyek baru di QGIS, dengan mengklik di ikon New Project.

../../../../_images/image172.png
  1. Pergi ke Layer ‣ Buat Lapisan ‣ Layer Shapefile Baru. Anda akan disajikan dengan dialog berikut ini:

../../../../_images/image173.png

Pada intinya kita harus memutuskan jenis dataset apa yang ingin kita buat. Ingat bahwa layer data hanya dapat mengandung fitur titik, garis, atau poligon – tidak pernah bercampur. Jadi kita harus mendefinisikan disini, ketika kita membuat layer, jenis data apa yang akan kita inginkan.

Karena polygon terdiri dari titik dan garis, mari kita coba dengan polygon. Setelah Anda menguasai ini, membuat layer titik atau garis seharusnya mudah!

  1. Beri tanda centang pada kotak Poligon.

../../../../_images/image174.png
  1. Kita akan menentukan Sistem Referensi Koordinat (CRS) di kotak sebelah. Secara standar kotak akan berisi project CRS, kita akan gunakan WGS 84. Ini adalah CRS yang banyak digunakan dan sangat berguna, jadi mari kita gunakan itu!

../../../../_images/image175.png
  1. Ketika kita membuat layer baru, tabel atribut hanya akan memiliki satu kolom standar - id. Atribut ini berisi nomor id unik untuk setiap fiturnya. Kita dapat menambah field baru ke tabel atribut sekarang, ketika kita membuat layer. Mari tambahkan nama field.

  2. Ketik nama di dalam kotak disebelah Name. Pengaturan harus sesuai dengan yang ditampilkan disini:

../../../../_images/image176.png
  1. Klik tombol Tambahkan ke daftar atribut.

Daftar atribut Anda harus terlihat seperti ini.

../../../../_images/image177.png
  1. Klik OK. Simpan dialog yang akan muncul.

  2. Navigasikan ke direktori yang Anda pilih.

  3. Simpan layer baru Anda sebagai gedung_kampus.shp.

Layer baru seharusnya muncul di daftar Layers Anda.

2. Data sources

Ketika Anda membuat data baru, ini jelas harus mewakili objek yang benar-benar ada di permukaan. Kita sudah mempelajari dari banyak cara untuk mengumpulkan data menggunakan tool OSM. Kita belajar mengenai GPS untuk merekam lokasi, Field Papers, dan tentu, citra satelit. Ini semua adalah alat yang kita dapat gunakan untuk mengidentifikasi lokasi dikehidupan nyata dan merekam mereka ke dalam layer data digital.

Di QGIS, kita dapat menggunakan jenis sumber yang sama untuk mendapatkan informasi mengenai permukaan bumi. Pada contoh ini, kita sekali lagi akan beralih ke citra satelit, tetapi bukannya menggunakan Bing, kita akan menggunakan gambar raster yang disediakan di direktori tutorial.

  1. Klik di tombol Add Raster Layer:

../../../../_images/image147.png
  1. Arahkan ke ../qgis/Sleman/.

  2. Pilih file UGM.tif.

  3. Klik Open. Gambar akan dimuat ke dalam peta Anda.

  4. Cari gambar baru di daftar Layers.

  5. Klik dan tarik ke bawah daftar sehingga di bawah layer vektor yang Anda buat di bagian sebelumnya.

../../../../_images/image178.png
  1. Pergi ke Proyek ‣ Properti Proyek dan aktifkan Aktifkan transformasi CRS “on the fly”

  2. Pastikan “WGS 84” terpilih sebagai CRS, dan klik OK.

../../../../_images/image179.png
  1. Klik kanan pada :guilabel:layer UGM, dan klik Perbesar ke Layer.

  2. Perbesar ke tengah gambar raster. Kita akan mendijitasi tiga area:

../../../../_images/image180.png

3. Digitising

Digitalisasi, yang seperti sudah Anda bisa duga, adalah seni (atau ilmu) untuk membuat data vektor digital dari sumber lain, seperti gambar raster. Untuk memulai dijitasi, kita harus masuk ke mode edit. Perangkat lunak SIG pada umumnya memerlukan mode terpisah untuk mengedit, untuk mencegah pengguna dari kesalahan mengedit atau menghapus data penting. Mode edit diaktifkan atau dimatikan secara individual untuk setiap layernya.

Mari kita masuk ke mode edit untuk :guilabel:layer gedung_kampus:

  1. Pilih gedung_kampus di panel Daftar Lapisan.

  2. Klik pada tombol Toggle Editing:

../../../../_images/image351.png
  1. Jika Anda tidak dapat menemukan tombol ini, pastikan bahwa toolbar Digitizing diaktifkan. Harus ada tanda centang di sebelah Tampilan ‣ Panel-panel ‣ Digitasi menu entri.

  2. Setelah Anda pada mode edit, alat dijitasi akan aktif:

../../../../_images/image1811.png

Dari kiri ke kanan pada gambar di atas, mereka adalah :

  • Toggle untuk Mengedit: mengaktifkan/menonaktifkan mode edit.

  • Simpan pengeditan layer: menyimpan perubahan yang dibuat di layer.

  • Add Feature: memulai dijitasi fitur baru.

  • Move Feature(s): memindahkan seluruh fitur ke sekitar.

  • Node Tool: memindahkan hanya satu bagian fitur.

  • Delete Selected: menghapus fitur terpilih (hanya aktif jika fitur dipilih).

  • Cut Features: memotong fitur terpilih (hanya aktif jika fitur dipilih).

  • Copy Features: menyalin fitur terpilih (hanya aktif jika fitur dipilih).

  • Paste Features: menyisipkan fitur dipotong atau disalin kembali ke peta (hanya aktif jika fitur sudah dipotong atau disalin).

Kita ingin menambah fitur baru.

  1. Klik pada tombol Add Feature untuk memulai dijitasi:

../../../../_images/image182.png

Anda akan melihat bahwa kursor Anda menjadi tanda plus. Hal ini memungkinkan Anda untuk lebih akurat menempatkan titik yang Anda digitasi. Ingat bahwa saat Anda menggunakan alat digitasi, Anda dapat perbesar dan perkecil peta dengan menggulir roda mouse, dan Anda dapat menjelajah sekitar dengan menekan roda mouse dan menarik ke peta sekitar.

Fitur pertama yang akan Anda dijitasi adalah sebuah lapangan (dinamakan “GPS Field”):

../../../../_images/image183.png
  1. Mulailah dengan mengklik titik di suatu tempat di sepanjang tepi lapangan.

  2. Tempatkan titik lebih banyak dengan mengklik sepanjang tepi, sampai bentuk Anda tergambar lengkap menutup lapangan. Ini sangat mirip dengan menggambar polygon di JOSM.

  3. Untuk menempatkan titik terakhir, klik kanan dimana Anda ingin menempatkannya. Ini akan melengkapi fitur dan menunjukkan dialog Attributes.

  4. Isi nilai-nilai seperti yang ditampilkan disini:

../../../../_images/image184.png
  1. Klik OK. Anda telah membuat fitur baru!

Jika Anda membuat kesalahan selama mendijitasi fitur, Anda dapat mengeditnya nanti. Selesaikan dijitasi fitur dan kemudian ikuti langkah berikut ini:

  • Pilih fitur dengan alat Pilih Fitur:

../../../../_images/image185.png
  • Kemudian gunakan satu dari alat ini untuk mengedit fitur:

../../../../_images/image186.png Move feature(s) tools

untuk memindahkan seluruh fitur

../../../../_images/image187.png Node tools

untuk memindahkan hanya satu titik dimana Anda mungkin telah keliru pada saat menempatkan titik tersebut.

../../../../_images/image188.png Delete selected

untuk menyingkirkan fitur seluruhnya sehingga Anda dapat mencobanya lagi

Pergi ke Edit ‣ Undo atau tekan Ctrl+Z pada keyboard

untuk membatalkan kesalahan.

 

Sekarang cobalah sendiri:

  1. Digitasi sendiri sekolah dan tanah kosong. Gunakan gambar ini untuk membantu Anda:

../../../../_images/image189.png
  1. Ingat bahwa setiap fitur baru butuh memiliki nilai id unik!

Ketika Anda menyelesaikan menambah fitur ke layer, Anda harus menyimpan perubahan ke layer tersebut.

  1. Klik pada tombol Toggle Editing.

../../../../_images/image351.png
  1. Anda akan ditanya untuk menyimpan hasil edit Anda. Klik Simpan.

../../../../_images/image190.png

Sekarang Anda mengetahui bagaimana cara untuk membuat fitur poligon! Membuat layer titik dan garis juga sama mudahnya - anda hanya butuh untuk menentukan tipe dari layer ketika anda membuatnya, dan tentu saja anda hanya bisa membuat titik di layer titik dan garis di layer garis.

4. Georeferencing

Pada bagian sebelumnya kita mendigitasi sebuah gambar raster untuk membuat data vektor. Hal ini sama dengan ketika kita akan menggunakan citra Bing ke dalam JOSM untuk menambahkan data OpenStreetMap. Pada dua kasus tersebut, citra yang kita gunakan sudah tergeoreferensikan - yang sama artinya dengan telah diletakkan secara tepat sesuai dengan posisi yang ada di permukaan bumi.

Ketika sebuah gambar telah tergeoreferensikan, gambar tersebut telah ditarik diberbagai macam arah sehingga setiap piksel dalam gambar tersebut mempunyai posisi yang sama dengan posisi yang ada di permukaan bumi. Karena terkadang sangatlah susah untuk memposisikan gambar datar ke dalam objek bulat, sehingga seringkali muncul kesalahan pada georeferensi, yang kita kenal dengan pergeseran citra/imagery offset.

Bagaimana jika Anda mempunyai peta yang belum tergeoreferensikan? Bagaimana jika Anda diberikan oleh pemerintah sebuah peta kertas? Bagaimana Anda mendigitasinya?

Langkah pertama yang Anda lakukan adalah mengubah peta kertas tersebut ke dalam format digital sehingga Anda bisa memanipulasinya dengan komputer Anda. Anda dapat melakukan hal ini dengan sebuah scanner (atau sebuah kamera digital), meskipun untuk melakukannya tidak disertakan di dalam bab ini.

4.1 Cara Georeferensi

Sekarang anda akan belajar bagaimana cara meng-georeferensikan sebuah gambar di QGIS sampai terposisikan sempurna sesuai dengan lokasi yang ada di permukaan bumi. Kita akan menggunakan peta yang telah disediakan di dalam tutorial, yang akan terlihat seperti ini:

../../../../_images/image191.jpg
  1. Mulailah membuat proyek QGIS baru. Simpan proyek lama Anda jika Anda menginginkan.

  2. Arahkan ke Raster ‣ Georeferencer ‣ Georeferencer.

../../../../_images/image192.png
  1. Klik tombol Open raster.

../../../../_images/image193.png
  1. Cari file peta_krb_merapi_2002.jpg, yang berlokasi di folder qgis/Sleman/Merapi/ . Klik Buka.

  2. Pilih WGS 84 jika diminta, kemudian klik OK.

../../../../_images/image194.png

Untuk meng-georeferensikan gambar ini, kita membutuhkan titik yang menghubungkan antara gambar dengan lokasi yang diketahui pada permukaan bumi. Titik tersebut dinamakan Ground Control Points (GCP). Untungnya peta ini telah mempunyai koordinat lintang dan bujur yang ditulis disetiap sudutnya. Sehingga, untuk meng-georeferensikan gambar ini, kita akan membuat empat titik kontrol/GCP disetiap sudut pada peta, dan kita akan mengubahnya menjadi geotiff, sebuah gambar yang telah di georeferensikan.

  1. Perbesar pada bagian kiri atas dari peta menggunakan tombol perbesar.

../../../../_images/image195.png
  1. Klik tombol Add point.

../../../../_images/image196.png
  1. Klik pada sudut kiri atas dari peta, tepat dimana garis border bagian atas bertemu dengan garis border bagian kiri.

  2. Sebuah kotak akan muncul meminta koordinat X dan Y pada titik yang telah Anda klik. Koordinat tersebut telah tertulis dengan huruf berwarna biru pada peta. Titik koordinat bujur (koordinat X) adalah 110° 15’ 00” E dan titik koordinat lintang (koordinat Y) adalah 7° 29’ 47” S. Kita bisa memasukkan koordinat pada kotak tersebut sesuai dengan apa yang telah kita lihat. Harap diingat bahwa nilai koordinat Lintang Selatan bernilai negatif.

../../../../_images/image197.png
  1. Klik OK.

  2. Anda akan melihat titik berwarna merah muncul pada lokasi titik kontrol/GCP Anda, dan sebuah tabel akan muncul pada bagian bawah.

  3. Ulangi proses ini, membuat titik kontrol pada setiap sudut dari peta. Harap dingat untuk memasukkan nilai koordinat lintang dan bujur sesuai dengan apa yang tertulis di setiap sudut. Ketika anda sudah selesai, anda akan mempunyai 4 titik kontrol dan table anda akan terlihat seperti ini:

../../../../_images/image198.png

Terakhir, kita akan mengatur dan membuat berkas hasil dari georeferensi kita.

  1. Klik pada tombol Transformation settings.

../../../../_images/image199.png
  1. Pada Jenis transformasi pilih Linear.

  2. Berikan nama untuk hasil raster. Jenis file tersebut akan berformat .tif.

  3. Centang kotak disamping tulisan Muat dalam QGIS ketika selesai. Tampilan Anda harus terlihat seperti ini:

../../../../_images/image200.png
  1. Klik OK dan lihat pada tabel.

../../../../_images/image2011.png
  1. Pastikan nilai sisa mendekati nol untuk meningkatkan akurasi.

  2. Sekarang kita telah siap untuk membuat berkas gambar yang telah di georeferensi. Klik pada tombol Start georeferencing.

../../../../_images/image202.png
  1. Jika Anda diminta untuk memilih sistem koordinat layer Anda, pilih WGS 84.

  2. Pergi ke Project ‣ Project Properties dan pastikan transformasi on the fly telah diaktifkan.

../../../../_images/image203.png
  1. File hasil akan dibentuk dan secara otomatis ditampilkan pada proyek Anda. Jika Anda mengarahkan kursor Anda ke gambar, Anda melihat koordinat di bagian bawah QGIS dimana koordinat berubah sesuai dengan lokasi titik kontrol yang Anda tempatkan.

../../../../_images/image204.png

Salah satu cara untuk melihat apakah gambar tersebut telah terposisikan sempurna adalah dengan menggunakan plugin OpenLayers. Disini kita akan menambahkan citra satelit Bing dan membuat gambar baru kita transparan untuk melihat latar belakang merapi di belakangnya.

../../../../_images/image205.png

Mengetahui cara untuk meng-georeferensi itu penting karena ketika Anda ingin mendigitasi dari sebuah peta kertas atau gambar yang belum memiliki informasi spasial. Ketika Anda telah meng-georeferensikan sebuah gambar dengan cara ini, Anda dapat melakukan teknik digitasi sesuai dengan apa yang telah kita pelajari sebelumnya, yang nantinya dapat digunakan di QGIS dan InaSAFE.

Lanjut ke modul selanjutnya –>