../../_images/5_000.png

Bab 5: Mengedit dengan JOSM

Tujuan Pembelajaran

  • Dapat menggunakan alat (tool) edit di JOSM

  • Mengetahui tombol-tombol pintas di JOSM

  • Mengetahui plugin-plugin di JOSM

  • Mengetahui kesalahan-kesalahan serta tips-tips mengedit

  • Mengetahui dan memahami tahapan-tahapan mengedit di JOSM

  • Dapat menyimpan file OSM

Pada sesi sebelumnya Anda telah menginstal JOSM dan mempelajari bagaimana operasi-operasi dasar di JOSM seperti menggambar titik. garis, dan poligon. Anda juga telah dapat menambah preset ke objek yang Anda buat untuk melampirkan informasi mengenai objek tersebut . Pad aakhirnya, Anda dapat menggambar peta Anda sendiri di JOSM.

Pada sesi ini kita akan melihat lebih dekat pada antarmuka JOSM dan juga bagaimana kita bisa memaksimalkan beberapa alat yang ada di JOSM untuk membantu kita dalam melakukan editing.

5.1 Tools Editing di JOSM

Di sini kita akan melihat beberapa tool dasar dan teknik yang ada untuk menggambar fitur di JOSM, dan pada bab berikut kita akan melihat lebih dalam untuk tool menggambar lanjutan. Jika Anda suka untuk mengikuti dan mempraktikkan penggunaan tool JOSM, silahkan Anda download di Edit tools kemudian buka JOSM dan file yang telah didownload. Ini akan terlihat seperti ini:

../../_images/5_001.png

Tampilan file latihan mengedit di JOSM

5.1.1 Alat Menggambar

JOSM memiliki beberapa tool tambahan yang menjadikan pembuatan garis dan poligon dengann kualitas tinggi lebih mudah. Tool ini dapat ditemukan dalam menu Alat di bagian atas JOSM. Anda juga dapat melihat terdapat banyak fungsi lainnya yang dapat membantu Anda menggambar garis, poligon, dan mengedit objek pada peta. Kita akan mendiskusikan alat-alat paling enting pada sesi ini.

../../_images/5_002.png

Pilihan yang ada di Menu Alat pada JOSM

Dalam mengaplikasikan fungsi dalam menu ini, Anda terlebih dahulu harus memilih sebuah titik, garis, atau poligon pada jendela peta. File contoh yang berisi macam elemen yang berlabelkan nama tool yang berbeda-beda di dalam menu.

  1. Cobalah memilih salah satu elemen di file tersebut. Kemudian pergi ke menu Alat dan klik fungsi yang diidentifikasi di sebelah fitur yang Anda pilih.

  2. Sebagai contoh, klik pada lingkaran yang tidak beraturan untuk memilihnya.

../../_images/5_003.png
  1. Selanjutnya, klik Alat ‣ Sejajarkan Node Membentuk Lingkaran

  2. Lingkaran yang tidak beraturan akan menjadi lebih simetris.

Percobaan dengan masing-masing tool menggunakan file contoh ini. Penjelasan mengenai beberapa tool lainnya disediakan di bawah ini.

  • Split Way/Memisahkan garis/way: Memungkinkan Anda untuk membagi sebuah garis menjadi dua garis terpisah. Ini berguna jika Anda ingin menambahkan atribut ke bagian jalan yang berbeda, seperti jembatan. Untuk menggunakan fungsi ini, pilih sebuah titik di tengah garis yang ingin Anda potong, kemudian pilih Memisahkan garis/way dari menu Tools, dan garis Anda seharusnya akan terpotong menjadi dua.

  • Combine Ways/Menggabungkan garis/way: Ini merupakan kebalikan dari Split Way. Untuk menggabungkan dua garis menjadi satu garis, mereka harus berbagi satu titik. Untuk menggunakan fungsi ini, pilih kedua garis yang ingin Anda gabungkan. Anda dapat memilih lebih dari satu objek dengan menahan tombol SHIFT pada keyboard Anda dan mengklik di setiap garisnya. Ketika Anda memilih kedua garis tersebut, pilih Tools ‣ Menggabungkan garis/way.

../../_images/5_004.png

Hasil menggabungkan garis/way di JOSM

Catatan

Jika Anda ingin menggabungkan jalan yang memiliki arah yang berbeda, Anda akan mendapatkan peringatan seperti ini:

../../_images/5_005.png

Jika jalan sudah terhubung, dan ingin berada pada arah yang sama, caranya dengan klik Reverse and Combine.

  • Reserve Way/Membalikkan Jalur-Jalur: Hal ini akan mengubah arah pada garis. Semua garis di dalam OSM memiliki sebuah arah, yang ditunjukkan di dalam JOSM dengan panah pada garis. Arah biasanya bukan masalah, kecuali pada kasus dimana jalan satu arah dan sungai yang mengalir dalam arah tertentu. Pada kasus ini Anda mungkin perlu membalikkan jalan sehingga garis tersebut dalam arah yang benar.

../../_images/5_006.png
  • Simplify Way/Sederhanakan Jalur: Jika garis Anda memiliki terlalu banyak titik di dalamnya dan Anda ingin membuatnya lebih sederhana, alat ini akan menghapus beberapa titik dari sebuah garis tanpa mempengaruhi bentuk .

../../_images/5_007.png

Contoh garis yang akan disederhanakan di JOSM

  • Align Nodes in Circle/Sejajarkan Node Membentuk Lingkaran: Jika Anda mencoba membuat sebuah bentuk lingkaran, gambarlah semampu Anda dan kemudian pilih objeknya. Fungsi ini akan membantu mengatur titik-titik untuk membuat lingkaran yang sempurna.

  • Create Circle/Buat Lingkaran: Sebagai alternatif, Anda dapat menggunakan tool ini, tool ini akan membuat lingkaran yang sempurna. Menggambar sebuah garis yang mewakili diameter dari lingkaran Anda.

../../_images/5_008.png
  • Align Nodes in Line/Sejajarkan Node dalam Garis: Fungsi ini akan menyelaraskan rangkaian titik menjadi garis lurus. Sebaliknya dengan garis yang panjang untuk memilih bagian dari garis yang akan diluruskan hati-hati karena hal ini memiliki kecenderungan untuk pergeseran garis walaupun sedikit.

../../_images/5_009.png

Konsep membuat garis yang berbelok menjadi garis lurus

  • Orthogonalize Shape/Ortogonalisasi Bentuk: Fungsi ini sangat berguna untuk menggambar bentuk teratur seperti bangunan. Setelah Anda menggambar sebuah area, fungsi ini akan membentuk kembali menjadi sudut-sudut persegi.

../../_images/5_010.png

Konsep menyempurnakan bentuk poligon

  • Unglue Way/Memisahkan titik atau garis: Tool ini memungkinkan Anda untuk melepaskan titik-titik yang terhubung. Sebagai contoh, kesalahan yang sering terjadi adalah jalan yang menempel dengan titik di sudut bangunan. Tentu saja jalan tidak bergabung dengan bangunan, sehingga ini adalah kesalahan, dan Anda dapat melepaskan objek satu dengan yang lain.

../../_images/5_011.png

Sebuah pertanyaan umum adalah bagaimana memutar sebuah garis atau poligon setelah objek tersebut tergambar.

  • Untuk memutar sebuah objek, pertama pilih objeknya.

  • Tahan SHIFT+CTRL pada keyboard Anda

  • Klik dan geser mouse untuk memutar

../../_images/5_012.png

Konsep untuk memutar objek di JOSM

5.1.2 Tombol Pintas di Keyboard

Setelah melakukan editing di OpenStreetMap, Anda akan menyadari bahwa Anda banyak membuang waktu untuk mengklik pada menu dan submenu. Untuk mengatasi hal ini, JOSM memiliki tombol pintas keyboard untuk mengganti proses menu yang panjang. Anda dapat memilih objek langsung dan menekan sebuah tombol pada keyboar Anda. Disini ada beberapa tombol pintas lain yang sering digunakan.

  1. Pilih Objek
    ../../_images/5_013.png
  2. Gambar Node
    ../../_images/5_014.png
  3. Zoom Tool
    ../../_images/5_015.png
  4. Hapus Objek
    ../../_images/5_016.png
  5. Perbesar
    ../../_images/5_017.png
  6. Perkecil
    ../../_images/5_018.png

5.1.3 Plugin di JOSM

Ketika Anda sudah bisa terampil dalam mengedit peta Anda, Anda mungkin ingin menggunakan fitur JOSM tambahan untuk meningkatkan keterampilan pemetaan Anda. JOSM memungkinkan Anda untuk menginstal berbagai plugin, kemudian menambahkan fungsi tambahan ke perangkat lunak. Pada sesi ini kita akan melihat beberapa plugin yang sangat berguna yang sudah tersedia di JOSM.

  • buildings_tools: Jika Anda menggambar banyak bangunan, ini akan membuat proses menggambar lebih cepat dan mudah. Plugin Building Tools sangat membantu untuk digitalisasi bangunan. Ini memungkinkan Anda untuk mendigitasi satu sisi bangunan persegi, dan dengan mudah memperpanjang bentuk. Jika Anda mendijitasi banyak bangunan, plugin ini akan menghemat klik, dan menghemat waktu Anda. Setelah plugin terinstal Anda akan melihat tombol baru di bagian sisi kiri JOSM, yang terlihat seperti ini:

    ../../_images/5_019.png
    1. Buka JOSM dan membuat layer kosong baru

    2. Pilih building_tools dan klik ganda untuk menggambar sebuah garis pada peta

    3. Kemudian geser mouse Anda dan klik kembali untuk menggambar sebuah persegi seperti gambar dibawah ini

    ../../_images/5_020.png
    ../../_images/5_021.png

    Proses menggambar bangunan dengan building tools

    1. Ini tidak hanya membuat sebuah persegi panjang dengan tiga kali klik, tetapi juga akan secara otomatis menerapkan tag building=yes ke poligon.

    Membuat Bangunan Kompleks

    Anda juga dapat membuat bangunan yang lebih rumit dengan terlebih dahulu menggambar beberapa overlap dan kemudian menggabungkan mereka bersama-sama.

    1. Menggambar dua bangunan yang overlap, sehingga mereka berbentuk L.

    2. Pilih kedua bangunan (tahan SHIFT untuk memilih lebih dari satu objek).

    3. Pergi ke Tools > Gabungkan area yang tumpang tindih atau tekan SHIFT+J pada keyboard Anda.

    ../../_images/5_022.png
  • Direct Upload: Jika Anda mengumpulkan banyak trek GPS dan Anda ingin menyimpannya di database OSM, plugin ini akan mempermudah Anda.

  • editgps: Jika Anda ingin mengupload trek GPS dari perangkat Garmin, Anda mungkin perlu menggunakan plugin ini. OSM tidak akan menerima trek GPS yang telah disimpan pada kartu memori eksternal di Garmin, tetapi plugin ini dapat memperbaiki file sehingga mereka dapat diupload.

  • fieldpapers: Plugin ini memuat Field Papers yang telah discan di dalam JOSM.

  • imagery_offset_db: Plugin ini bekerja sama dengan pembuat peta yang menemukan citra satelit Bing yang tidak sejajar. Masalah ini dibahas lebih detail dalam bab selanjutnya.

  • mirored_download: Dengan plugin ini, Anda dapat mendownload data OSM dengan area yang lebih luas untuk mengedit.

  • print: Menambahkan fungsi Print, Jika Anda ingin mencetak sebuah area dengan cepat dan tidak perlu terlihat sangat baik.

  • utilsplugin2: Menambahkan banyak tool tambahan dan menu pada JOSM.

    Jika Anda belum selesai, berikut instruksi cara menginstal plugin ini di JOSM Plugin <http://learnosm.org/bi/editing/josm-plugins>`__.

../../_images/5_023.png

Tampilan dari tilsplugin 2

Setelah Anda menginstall plugin ini dan restart JOSM, Anda akan memiliki sebuah menu baru di atas yang bernama More Tools seperti ditunjukkan gambar di bawah.

../../_images/5_024.png

Pilihan menu more tools di JOSM

Membuat layer baru dan berlatih dengan beberapa tools baru. Kita akan menjelaskan beberapa dari tools baru yang sangat berguna:

  • Add Node at Intersections Tambah node atau titik di persimpangan: Tool ini sangat berguna untuk menambahkan titik yang hilang di persimpangan garis yang terpilih. Ini baik untuk dipratekkan bahwa jalan seharusnya selalu memiliki titik di mana mereka berpotongan.

../../_images/5_025.png

Menambahkan node/titik di persimpangan

  • Copy Tags from Previous Selection/Salin tag dari pilihan sebelumnya: Fungsi ini sangat berguna untuk menyalin sebuah tag dengan mudah. Jika Anda ingin membuat banyak objek dengan tag yang sama. Klik pada objek yang lain dan tekan SHIFT+R untuk menyalin tag dari objek yang dipilih sebelumnya. Anda dapat melakukan ini untuk semua objek yang ingin Anda beri tag. Ingatlah bahwa tag akan disalin dari objek yang terpilih sebelumnya, jika Anda mengklik pada objek yang belum diberi tag, maka fungsi ini tidak dapat berjalan.

../../_images/5_026.png

Menyalin tag dari bangunan yang dipilih

  • Add Source Tag/Tambahkan tag sumber: Tool ini untuk menyederhanakan dalam menambahkan sumber tag, ini mengingat bahwa sumber yang ditentukan terakhir dan menambahkannya sebagai sumber data ke objek Anda. Anda dapat memasukkan sumber dengan hanya mengklik satu kali.

  • Replace Geometry/Ganti Geometri: Tool ini sangat berguna jika Anda ingin memperbaiki gambar objek, tetapi riwayat, atribut, dan objek ID tersebut tetap tidak berubah. Contohnya, Jika Anda menemukan sebuah bangunan yang rumit dan digambarkan dengan cara yang tidak sesuai, maka untuk mengubah setiap titiknya, Anda dapat menggambar objeknya kembali, memilih objek lama dan baru, dan pilih guilabel:Ganti Geometri, untuk mentransfer semua informasi di atas.

../../_images/5_027.png

Mengganti bentuk objek di JOSM

Tool Selection

Utilsplugin2 juga menyediakan lebih banyak tool pada menu Selection. Cobalah bereksperimen dengan tool tersebut.

../../_images/5_028.png

Tampilan menu tools Selection

Salah satu tool selection yang sering kita gunakan adalah Membatalkan pilihan node/titik: Tool ini membatalkan pilihan semua titik. Ini dapat berguna jika Anda menggambar kotak untuk memilih banyak objek, tetapi Anda tidak ingin memilih titik yang berisi semua garis dan poligon. Seperti ditunjukkan pada gambar di bawah ini

../../_images/5_029.png

Contoh membatalkan node/titik di JOSM

5.2 Tips Editing

Ada beberapa kesalahan umum yang dilakukan pembuat peta ketika mereka memulai menggunakan OpenStreetMap. Pada bab ini, kita akan mengidentifikasi beberapa kesalahan yang sering dilakukan dan memberikan beberapa tips untuk memetakan lebih baik.

5.2.1 Objek yang saling Terhubung

Beberapa Objek Sebaiknya tidak Terhubung

Ketika Anda membuat poligon dan garis yang tidak seharusnya terhubung, pastikan mereka tidak terhubung oleh satu titik. Sebagai contoh, titik pada jalan sebaiknya tidak menempel ke bangunan, karena tidak ada jalan yang langsung menempel dengan dinding! Jika anda ingin memutuskan hubungan dua atau lebih objek yang menempel di titik yang sama, pilih titik dan pergilah ke Menu Tools -> Memisahkan titik/garis atau tekan G seperti gambar di bawah ini.

../../_images/5_030.png

bangunan dan jalan yang tersambung

../../_images/5_031.png

bangunan dan jalan yang terpisah

Tetapi, Beberapa Objek Harus Terhubung

Jalan yang bersinggungan seharusnya selalu terhubung pada titik. Jika mereka tidak terhubung pada satu titik, maka komputer tidak mengetahui bahwa jalan tersebut sebenarnya saling terhubung satu sama lain. Maka dari itu jika anda melihat ada jalan yang tidak saling terhubung satu sama lain silahkan perbaiki dengan pilih node/ titik dari jalan yang ingin dihubungkan kemudian pergilah ke Menu Tools -> Gabungkan Node atau tekan M pada keyboard Anda dan geser.

../../_images/5_032.png

Jalan harus terhubung satu sama lain

5.2.2 Objek yang Saling Overlap

Salah satu kesalahan umum adalah poligon saling overlap ketika objek yang digambarkan sebenarnya tidak saling overlap. Sebuah bangunan tidak bisa overlap dengan bangunan yang lain. Sebagai contoh, poligon yang dibangun untuk menggambarkan taman diluar bangunan sebaiknya tidak saling overlap dengan bangunannya. Seharusnya digambar di sebelah bangunannya.

../../_images/5_033.png

Contoh bangunan yang saling overlap

Ada beberapa pengecualian pada aturan ini, se­perti sekolah. Di dalam halaman sekolah mungkin Anda ingin mengidentifikasi bangunan menggunakan poligon, tapi mungkin Anda juga ingin membuat sebuah poligon yang meliputi seluruh halaman sekolah. Dalam kasus seperti ini, poligon diper­bolehkan untuk saling overlap, tetapi aturannya adalah pastikan bahwa bangunan­ se­cara menyeluruh berada dalam poligon peng­gunaan lahan.

../../_images/5_034.png

Contoh overlap bangunan yang salah dan benar

5.2.3 Kesalahan-Kesalahan yang Lain

Tag Diberikan pada Node, Bukan pada Bangunan

../../_images/5_035.png

Contoh bangunan yang diberikan tag dengan salah (kiri) dan benar (kanan)

Satu masalah umum yaitu menambahkan tag pada node yang terdapat pada bagian dari sebuah garis atau poligon. Ini sering terjadi ketika seseorang menggambar sebuah bangunan dan kemudian memilih satu dari titik yang ada disekitar gambar tersebut. Cara untuk menghindari hal ini, dengan klik secara langsung pada garis.

Persimpangan yang Bertemu di Sudut Jalan/Persimpangan Jalan Harus Dipisah

../../_images/5_036.png

Pembuatan simpangan yang salah (kiri) dan benar (kanan)

Ketika jalan bersinggungan satu sama lain di sudut jalan, Anda tidak boleh membuat garis melengkung di persimpangan. Garis seharusnya berbentuk sudut 90°, seperti dikondisi sebenarnya.

Tidak ada Tag pada Node atau Garis

../../_images/5_037.png

Untuk memperbaiki ini, pilih objek dan tag objek yang sesuai dengan informasi yang dideskripsikan objek tersebut. Kemungkinan, objek bisa di hapus bila itu adalah kesalahan.

Garis Berada Dekat dengan Garis Lain Tetapi Tidak Terhubung

Gambar di bawah ini menunjukkan sebuah contoh dari garis yang seharusnya terhubung tetapi tidak

../../_images/5_038.png

Contoh dari garis tidak saling terhubung

Untuk memperbaikinya, Anda bisa memilih titik dari garis yang ingin dihubungkan dan kemudian pilih Gambar node untuk menambahkan titik di akhir garis. Alternatif lainnya, Anda bisa menggunakan Gabungkan Node (jika didepan garis yang belum terhubung tersebut merupakan sebuah titik), caranya:

  1. Pilih kedua titik yang berdekatan, yang berada di dalam kedua garis yang ingin dihubungkan

  2. pilih menu Tools > Gabungkan Node

Jika di depan garis yang belum terhubung tersebut tidak terdapat sebuah titik, Anda bisa menggunakan tool pada Tools > Menggabungkan node/titik men­jadi way/garis.

Garis Tidak Boleh Melewati Bangunan

Pada gambar di bawah, sebuah fitur linear berjalan langsung melalui sebuah bangunan.

../../_images/5_039.png

Contoh garis melewati bangunan

Untuk mengatasinya, Anda perlu melihat menggunakan citra satelit objek mana yang berada pada lokasi yang salah. Jika sudah, Anda tinggal menggeser objek tersebut ke tempat yang sesuai.

5.3 Tahapan Mengedit di JOSM

Mengedit OpenStreetMap dengan JOSM sama dengan mengedit dengan iD editor. Namun karena JOSM adalah aplikasi desktop, akan ada sedikit perbedaan. Berikut adalah proses mengedit dan menambahkan ke OpenStreetMap dengan JOSM yang tahapannya sebagai berikut:

  1. Download data peta yang terbaru dari OSM

  2. Edit ini menggunakan citra satelit, GPS atau FieldPapers

  3. Save perubahan ke OpenStreetMap

Pada bagian ini, kita akan mempelajari hal secara lebih rinci

5.3.1 Mendownload Data OSM

Langkap pertama mengedit adalah mendownload data untuk area yang akan kita tambahkan. Perhatikan bahwa Anda perlu melakukan ini setiap waktu sesuai dengan keinginan Anda untuk melakukan perubahan pada peta, karena peta ini sering kali diperbarui oleh pengguna lain.

  1. Klik pada File di sudut kanan atas JOSM dan klik Download dari OSM. Kemudian jendela download akan terbuka. Anda juga dapat mengakses jendela ini dengan mengklik pada tombol download, seperti ini:

../../_images/5_040.png
  1. Ketika jendela download terbuka, Anda akan melihat peta dengan kotak berwarna merah muda yang tergambar di dalamnya. Jika peta Anda tidak muncul, klik pada tab yang bertanda Pencarian peta secara cepat seperti ditunjukkan gambar di bawah ini.

../../_images/5_041.png

3. The pink box represents the area of interest that we would like to download for editing. Use your mouse to pan and zoom to an area that you know very well, such as your hometown or neighborhood. The controls are the same as in the JOSM map window. The right mouse button lets you drag the map, and your scroll wheel allows you to zoom in and out.

4. Draw a box around the area that you want to download. To draw a new box, click on the map, hold your left mouse button down, and drag your mouse to create a box. Release the mouse button to finish drawing the box.

5. When you are satisfied with the size and location of the box, click Download at the bottom of the window. JOSM will fetch the data for this area from OpenStreetMap and open it in your map window for editing.

../../_images/5_042.png

5.3.2 Menambahkan Citra Satelit

Jika Anda masih mengingat cara mengedit menggunakan iD editor, Anda perhatikan bahwa di bawah data peta terdapat citra satelit yang dapat membantu kita untuk mengidentifikasi objek di permukaan. Citra satelit ini berasal dari Microsoft Bing, yang menyedikan citra satelit ini untuk para pengguna OpenStreetMap secara gratis sebagai referensi dalam berkontribusi untuk pemetaan.

Untuk menambahkan citra satelit Bing di JOSM, klik Citra Satelit di bagian menu atas JOSM dan pilihlah Bing Aerial Imagery.

../../_images/5_043.png

5.3.3 Mengedit dengan JOSM

Sekarang, kita telah melakukan beberapa langkah sebelum mengedit di JOSM, dimulai dengan mendownload data OSM dan menambahkan citra satelit sebagai latar belakang. Selanjutnya, kita akan mengedit peta dan menambahkan objek baru didalamnya.

Anda mungkin akan mendapat banyak atau sangat sedikit data peta di JOSM, tergantung dari luas area yang Anda gunakan. Tetapi perhatikan bahwa data itu adalah jenis data yang sama seperti data contoh yang telah kita pelajari sebelumnya seperti titik, garis, dan poligon yang mewakili lokasi kehidupan nyata.

  1. Menggunakan cara seperti yang Anda telah pelajari sebelumnya untuk menambah titik ke peta wilayah. Jika Anda melihat suatu kesalahan pada objek tersebut, cobalah untuk memperbaikinya.

2. You do not need to hurry, take your time to understand the steps. If you are not really sure about the outline or identify of some object, you should leave these off the map.

3. If you want to move nodes, lines, or polygon, you can use Select Tools. Click the object that you want to move and drag it to where it should be.This step could be used to fix location of objects which have wrong position.

../../_images/5_044.png

4. Use Draw Tool to draw nodes, lines, and polygon. Add description and information of your object using Presets menu. You have done this in previous chapter.

Layer JOSM

Anda mungkin telah memperhatikan bahwa setiap Anda menambahkan objek baru ke JOSM, objek Anda akan ditambahkan ke panel layer di sisi kanan JOSM. Panel Layers Anda mungkin terlihat seperti ini:

../../_images/5_045.png

Setiap item dalam daftar ini merupakan sumber data yang berbeda yang Anda telah buka di JOSM. Pada contoh yang ditunjukkan gambar di atas, Data Layer 1 adalah data OpenStreetMap yang kita edit. Bing Sat adalah layer citra satelit yang kita gunakan sebagai sebuah latar belakang di JOSM.

Layer-layer yang digunakan sebagai latar belakang untuk membantu identifikasi dan mendijitasi objek di JOSM. Seperti citra satelit, trek gps, dan hasil scan FieldPapers. Kita menyebutnya sebagai base layers atau latar belakang sedangkan layer dari data osm yang kita download adalah layer utama yang kita gunakan untuk digitasi dan melakukan editing, menambahkan objek, memindahkan objek, dsb.

  1. Untuk memindahkan sebuah layer, klik pada Layers dan klik tanda panah guilabel:ke atas atau ke bawah untuk memindahkannya.

../../_images/5_046.png
  1. Untuk menghilangkan sebuah layer, pilih layer dengan mouse Anda dan klik tombol Show/ Hide:

../../_images/5_047.png

Anda seharusnya melihat layer yang Anda telah pilih akan menghilang pada jendela peta. Klik tombol Show/Hide dan ini secara otomatis akan muncul di JOSM.

  1. Anda dapat menghapus sebuah layer dengan menggunakan tombol delete:

../../_images/5_048.png

4. Last, it is very important to know that you only can edit the Active layer in JOSM. If you can not edit your map in JOSM, it might be because your layer is not active. Most layer, such as GPS point, Field Papers, and Aerial Imagery cannot be edited. The only layer that can be edited are data from OpenStreetMap, which are usually called Data Layer 1.

  1. Untuk mengaktifkan suatu layer, pilih nama layer Anda pada panel Layer, kemudian klik tombol Aktifkan:

../../_images/5_049.png

Tag

Sebuah tag adalah seperti sebuah label yang Anda dapat letakkan ke suatu objek. Misalnya, jika kita menambahkan sebuah objek di beberapa area dan objek adalah sebuah masjid dan itu bernama Masjid Raya Sabilal Muhtadin; amenity adalah place of worship dan masjid merupakan tempat ibadah umat muslim. Anda dapat menambahkan religion=Muslim untuk masjid sebagai informasi lain yang Anda inginkan ke sebuah objek. Tag disimpan sebagai sepasang teks, terutama sebagai sebuah key dan values. Di OpenStreetMap, Anda dapat melihat semua informasi tentang sebuah objek di panel properti di sebelah kanan dari jendela JOSM seperti ditunjukkan pada gambar di bawah ini.

../../_images/5_050.png

Contoh Tag dari Objek di JOSM

Mengedit Tags

Anda dapat menambah, mengedit, dan menghapus tag dari panel Properties. Namun, tag secara manual dalam bahasa Inggris dan kadang-kadang dapat membingungkan terutama jika Anda tidak mengerti bahasa Inggris. Oleh karena itu, Anda lebih mudah mengatur tags menggunakan sebuah menu Presets. Ketika Anda menambah atau mengubah tag, atribut objek akan berubah.

  1. Untuk mengedit tag objek, pertama pilih ob­jeknya.

  2. Anda dapat mengedit tag: (1) Menggunakan Menu Presets, (2) Mengedit tag secara langsung di jendela Properties di sebelah kanan dari JOSM Anda.

5.3.4 Menyimpan Perubahan

Langkah ketiga dan terakhir untuk menyelesaikan hasil editan adalah untuk mengupload perubahan yang telah kita buat di database OpenStreetMap. Untuk menyimpan perubahan, kita harus terkoneksi dengan internet.

1. Click File on the top menu, and then click :guilabel: Upload Data. This will open up the upload window. You can access this window more simply by clicking on the upload button, shown here:

../../_images/5_051.png

2. The window that appears shows a list of the objects that you are adding and the objects you are modifying or deleting. In the box at the bottom you are asked to provide a comment about the changes that you are making. Type in here a brief description of your edits.

../../_images/5_052.png
  1. Klik Upload Perubahan

  2. Anda perlu menunggu beberapa detik untuk melihat perubahan Anda yang telah diupload, dan selesai! Anda telah mengedit di dalam OpenStreetMap.

5.3.5 Menyimpan File OSM

Ketika Anda mengedit di JOSM, Anda sebaiknya mendownload, mengedit, dan mengupload perubahan dalam interval waktu yang tidak lama. Jangan takut untuk mengupload hasil edit Anda sesering mungkin. Hal ini memastikan bahwa perubahan Anda akan disimpan ke dalam database OSM dan tidak akan kehilangan hasil kerja Anda. Ada kasus dimana, Anda belum selesai mengerjakan pekerjaan Anda, atau koneksi internet Anda terputus. Jika hal itu terjadi, Anda dapat menyimpan pekerjaan Anda di komputer. Caranya adalah sebagai berikut :

1. To save your OSM file, make sure your layer active. Click File > Save. Choose your location in your computer and give a name to your file. You also can save your file by click this button:

../../_images/5_053.png
  1. Anda sekarang dapat menutup JOSM dan data Anda akan tersimpan. Ketika Anda ingin membuka file itu kembali, buka JOSM, kemudian pergilah ke menu File > Buka.

5.3.6 Melihat Perubahan Anda di Peta

Untuk melihat perubahan Anda di peta, perhatikan langkah-langkah berikut:

  1. Buka browser internet Anda dan pergilah ke openstreetmap.org

  2. Geser peta ke area yang telah Anda edit.

  3. Anda seharusnya dapat melihat perubahan Anda yang akan muncul di peta! Jika tidak, coba me- nekan CTRL+R untuk merefresh halaman situs. Biasanya peta tidak memperbarui dengan sempurna dan perlu dimuat ulang

  4. Bagaimana jika Anda tidak melihat perubahan? Jangan khawatir - mungkin diperlukan beberapa menit untuk perubahan yang akan ditampilkan pada peta. Kemudian, periksa penambahan Anda di JOSM untuk memastikan bahwa yang Anda tambahkan benar. Aturan umum yang baik adalah jika titik Anda memiliki ikon di JOSM, kemudian hal ini seharusnya terlihat di peta utama pada situs OpenStreetMap.

5.4 Penjaminan Kualitas Data di JOSM

Berkontribusi di Openstreetmap merupakan hal yang mudah untuk dipelajari, namun sulit untuk dikuasai. Setiap orang dapat melakukan kesalahan, akan tetapi selalu ada orang lain yang siap membantu untuk menyelesaikan kesalahan tersebut. Seiring Anda melakukan pemetaan secara terus menerus, hal tersebut akan menjadi lebih mudah dan Anda akan mengerti cara yang tepat untuk melakukan pemetaan. Bab ini ditujukan untuk membantu Anda memberikan kontribusi yang lebih baik. Kita akan memulai dari mendiskusikan berbagai macam teknik mengedit di JOSM yang akan membuat Anda bekerja lebih baik dan mengerti kesalahan umum yang sering dibuat pada awal pemetaan. Kita akan mendiskusikan alat validasi JOSM dimana merupakan cara otomatis untuk mengecek kesalahan.

5.4.1 Peringatan dan Kesalahan di JOSM

Ada kalanya ketika Anda ingin upload hasil kerja Anda ke OpenStreetMap, ketika Anda mendapatkan sebuah jendela pemberitahuan seperti dibawah ini:

../../_images/5_054.png

Ini adalah cara JOSM memberitahu kita bahwa data tersebut ada yang salah dan harus diperbaiki sebelum mengupload ke server OSM.

JOSM hadir dengan alat validasi yang berfungsi untuk menganalisis secara otomatis kesalahan yang ada. Hal ini sangat membantu untuk menemukan kesalahan yang tidak terlihat oleh Anda. Ketika Anda menjalankan alat validasi ini, alat ini akan menghasilkan dua jenis masalah:

  • Kesalahan: Hal ini penting untuk diperbaiki, dan Anda seharusnya tidak mengabaikannya. Sebagai contoh dari kesalahan ini adalah objek yang terduplikasi atau garis dan poligon yang saling bertumpang tindih.

  • Peringatan: Kesalahan yang penting untuk diperbaiki, namun pada beberapa kasus hal tersebut bisa ditoleransi.

Satu hal yang perlu diperhatikan jika Anda mendownload area yang besar dan menjalankan alat validasi, Anda mungkin akan mendapatkan daftar kesalahan dan peringatan yang sangat panjang. Hal ini dikarenakan alat validasi ini bekerja pada seluruh peta, tidak hanya perubahan yang telah Anda buat. Sehingga Anda mungkin akan melihat kesalahan yang dibuat oleh orang lain dan Anda bisa memperbaikinya atau menghiraukannya. Akan tetapi alat validasi memberikan Anda kesempatan untuk melihat kesalahan satu persatu.

5.4.2 Menggunakan Alat Validasi

Mari kita lihat bagaimana cara menggunakan alat validasi

  1. Pada JOSM, download satu daerah pada peta. Jika Anda tidak melihat Hasil Validasi pada jendela di panel bagian kanan, klik pada ikon tanda centang berwarna biru pada bagian kiri di jendela JOSM Anda seperti gambar dibawah ini.

../../_images/5_055.png

Posisi tombol Validasi

  1. Pastikan bahwa tidak ada bagian pada peta yang dipilih. Jika Anda menjalankan alat validasi dengan sesuatu yang dipilih, hal tersebut hanya akan memvalidasi daerah yang Anda pilih, dan tidak seluruh peta. Arahkan mouse Anda pada jendela validasi dan klik Validasi

../../_images/5_056.png
  1. Peta tersebut akan berubah dan segala macam Peringatan akan terlihat berwarna kuning dan un- tuk kesalahan berwarna merah. Pada jendela Hasil Validasi Anda akan melihat daftar peringatan dan kesalahan, jika ada.

../../_images/5_057.png

Layer Validasi dan Hasil Validasi

  1. Kesalahan harus seluruhnya diperbaiki. Anda dapat memperbesar di daerah yang terdapat kesalahan dengan cara klik kanan pada kesalahan di jendela tersebut dan kemudian pilihlah Zoom to Problem. Setelah itu Anda bisa memperbaiki kesalahan tersebut secara manual.

5. Some errors can be automatically fixed, such as Duplicated node errors. You can click on the folder for these types of errors and click the Fix button in the window. Many errors, however, need to be corrected manually.

../../_images/5_058.png
  1. Biasanya terdapat lebih banyak Peringatan daripada Kesalahan. Dengan memberikan peringatan, JOSM memberitahukan Anda bahwa hal tersebut kemungkinan kesalahan, tapi tidak selalu. Sehingga Anda akan menggunakan keputusan anda untuk melihat apakah hal tersebut merupakan benar kesalahan atau tidak.

  2. Jika Anda memilih salah satu warning dari daftar dan memutuskan bahwa hal tersebut bukanlah masalah, klik abaikan dan warning tersebut akan di hapus dari daftar.

  3. Anda dapat menjalankan ulang alat validasi sewaktu-waktu dengan mengklik Validasi.

Ringkasan

Luar Biasa! Anda telah berhasil mempelajari bagaimana tahapan-tahapan yang tepat dalam mengedit peta OpenStreetMap di JOSM dan juga bagaimana kita bisa memaksimalkan beberapa alat yang ada di JOSM untuk membantu kita dalam melakukan editing peta kita. Anda juga mengetahui beberapa kesalahan-kesalahan yang harus kita hindari ketika melakukan editing di JOSM.

Pada sesi selanjutnya kita akan belajar bagaimana menggunakan Global Positioning System (GPS) untuk mengumpulkan data di lapangan ketika melakukan survey lapangan dan bagaimana menambahkannya ke dalam OpenStreetMap

bab selanjutnya –>