../../_images/1_0001.png

Bab 3: Dasar-dasar QGIS

Tujuan Pembelajaran

  • Men-download QGIS

  • Meng-install QGIS

  • Membuka proyek QGIS yang telah disimpan sebelumnya

  • Memahami panel layer

  • Mengakses tool dasar melalui toolbar

  • Membersihkan toolbar

  • Menampilkan peta melalui jendela peta

Pada bab ini kita mulai menggunakan QGIS. Kita akan lihat bagaimana cara menginstal memahami layout, tampilan antarmuka dan fungsi utama dari perangkat lunak ini. Pada akhir bab ini, Anda akan memulai jalan Anda untuk menjadi pengguna SIG yang kompeten!

Perhatikan jika Anda telah menginstal QGIS, lewati bagian pada sesi tiga. Sebaiknya, mari mulai dan QGIS terinstal.

3.1 Mendapatkan QGIS

  1. Buka browser internet Anda dan ketikkan pada bagian atas jendela browser Anda dengan tulisan qgis.org. Kemudian tekan Enter.

../../_images/3_0011.png

Situs resmi QGIS akan terlihat seperti ini:

../../_images/3_0021.png
  1. Klik Download Now

../../_images/3_0031.png
  1. Jika Anda menggunakan Windows, temukan versi Long Term Release dan klik pada QGIS Standalone Installer Version 2.14 (32 bit). Nomor versi komputer Anda mungkin berbeda.

../../_images/3_0041.png
  1. Jika Anda tidak menggunakan Windows, pilih Sistem Operasi Anda dari menu yang tersedia. Ikuti intruksi instalasi.

../../_images/3_0051.png
  1. Ketika file selesai didownload, jalankan dan ikuti perintah untuk menginstal QGIS.

3.2 Instalasi QGIS

  1. Buka folder dimana anda menyimpan file instalasi QGIS.

../../_images/3_0061.png
  1. Jalankan file instalasi tersebut. Jika Anda menginstal QGIS versi 2.x, akan terlihat seperti ini:

../../_images/3_0071.png
  1. Klik Next.

  2. Klik I Agree untuk setuju dengan syarat dan ketentuan yang berlaku pada persetujuan lisensi.

  3. Pada jendela berikutnya adalah pertanyaan dimana Anda akan menginstal QGIS. Pada kasus umum, pengaturan bawaan yang ada sudah dapat digunakan. Klik Next.

  4. Pada jendela berikutnya, klik Install tanpa mencentang apapun yang ada di dalam kotak.

QGIS akan memulai untuk menginstall. Ini mungkin akan membutuhkan beberapa waktu untuk selesai.

  1. click Finish to complete the installation.
  2. Sekarang buka QGIS dari Start Menu.

../../_images/3_0131.png

Tampilan QGIS akan terlihat seperti ini:

../../_images/3_0141.png

3.3 Layout tampilan antarmuka pengguna QGIS

Selanjutnya kita akan membuka sebuah proyek QGIS dan melihat beberapa perbedaan dari tampilan antarmuka QGIS. Jika Anda sebelumnya Anda sudah menginstal InaSAFE, pastikan QGIS tersebut sudah tertutup dengan mengklik tombol X pada bagian kanan atas dari panel InaSAFE. Jika belum, teruskanlah. Kita akan kembali lagi pada hal ini nantinya.

  1. Klik ikon folder pada toolbar paling atas atau pergi ke Project ‣ Buka...

../../_images/3_0151.png
  1. Navigasikan ke file tutorial QGIS dan masuk ke ** direktori QGIS for Disaster Management/. Buka file bernama **Chapter_3_BasicQGIS.qgs. Tampilan QGIS akan terlihat seperti gambar di bawah ini. Mari kita berhenti sejenak dan pergi ke beberapa komponen yang terdapat pada tampilan antarmuka QGIS.

../../_images/3_0161.png

Kanvas Peta

Ini akan membuka jendela dimana peta yang kita buat ditampilkan. Proyek kita terdiri dari dua file yang berbeda, satu yang menggambarkan kecamatan dari kabupaten Sleman, dan satu lagi menjelaskan bahwa terdapat rel kereta yang melintas melalui area. Anda dapat melihat kedua file ini akan digambar pada area yang sama di Map Canvas.

Panel Layer

Pada bagian kiri QGIS terdapat daftar layer. Daftar ini menampilkan layer-layer, atau file, yang dimasukkan ke dalam proyek QGIS. Pada proyek ini, kita memliki dua layer, Kecamatan_Sleman dan railway_Sleman_OSM.

Panel layer tidak hanya menunjukkan semua file yang kita buka, tetapi juga menjelaskan susunan urutan yang akan kita gambar pada map canvas. Sebuah layer yang terdapat di posisi paling bawah akan tergambar pertama kali dan beberapa layer yang terdapat diatasnya akan digambar pada posisi paling atas.

  1. Klik pada layer railway_Sleman_OSM dan geser ke bawah layer yang bernama Kecamatan_Sleman.

../../_images/3_0171.png

Perhatikan bahwa tampilan peta berubah. Layer rel kereta api sekarang terlihat di bawah layer kecamatan dan bagian dari rel kereta sekarang diburamkan. Peta tidak akan menampilkan rel kereta yang terletak tersembunyi di bawah area kecamatan. Sekarang kembalikan layer tersebut ke posisi semua.

  1. Hilangkan semua tanda centang pada layer yang ada. Hal tersebut akan menyembunyikan layer dari map canvas.

  2. Anda dapat menampilkan detail dari layer dengan meng-klik tombol panah atau simbol plus di samping layer Anda. Hal ini akan memberikan Anda infomasi lebih lanjut mengenai tampilan layer saat ini.

../../_images/3_0181.png
  1. Klik kanan pada layer untuk melihat menu dengan tampilan pilihan tambahan. Nantinya Anda akan menggunakan beberapa menu tersebut, jadi sekarang saatnya Anda mengeksplorasi sejenak. Selamat mencoba!

Toolbars

Pada bagian atas dari tampilan QGIS terdapat banyak sekali tool, yang tergabung dalam berbagai toolbar. Sebagai contoh, toolbar File memungkinkan Anda untuk menyimpan, membuka, mencetak dan memulai proyek baru. Kita telah menggunakan salah satu alat dari tool ini ketika kita membuka proyek ini.

../../_images/3_0191.png

Dengan mengarahkan mouse Anda kepada icon yang tersedia, nama tool tersebut akan muncul untuk membantu Anda mengidentifikasi setiap tool.

Jumlah tool (tombol) yang ada akan tampak sangat banyak pada awalnya, tapi Anda perlahan akan mengenalnya. Tools yang ada dikelompokkan sesuai dengan fungsi pada toolbars. Jika Anda melihat lebih dekat, Anda akan melihat 10 titik-titik vertikal pada bagian kiri dari setiap toolbar. Jika Anda meng-klik dan menahannya dengan menggunakan mouse Anda, Anda dapat menggerakkan toolbar ke tempat yang lebih sesuai atau memisahkannnya sesuai dengan keinginan Anda.

../../_images/3_0201.png

Jika Anda merasa terganggu dengan jumlah toolbar yang ada, Anda dapat mengubah tampilannya dengan menampilkan tool yang Anda sering gunakan saja, menambahkan atau menghapus toolbar sesuai keperluan.

  1. Untuk menambahkan atau menghapus toolbar, klik kanan pada toolbar atau pergi ke Tampilan ‣ Panel alat-alat.

../../_images/3_0211.png
  1. Mari sekarang kita hilangkan beberapa toolbar yang kita rasa tidak digunakan pada pelatihan ini, untuk membuat tampilan lebih bersih. Klik kanan pada toolbar, dan hilangkan tanda centang kotak yang berada di toolbar berikut ini:

    • Digitalisasi Tingkat Lanjut

    • Basis Data

    • GRASS
    • Label
    • Raster
    • Vektor

  2. Setelah menghilangkan dan memindahkan beberapa toolbar, tampilan tools Anda mungkin akan terlihat seperti ini:

../../_images/3_0221.png

Meskipun tidak terlihat pada toolbar, semua tool-tool Anda akan tetap bisa diakses melalui Menu. Sebagai contoh, jika Anda menghilangkan toolbar File (yang terdapat tombol Simpan), Anda masih dapat menyimpan peta Anda dengan pergi ke Project ‣ Simpan.

Status Bar

Status bar akan menampilkan informasi mengenai peta Anda. Ini juga memperbolehkan Anda untuk mengatur skala peta dan melihat koordinat yang mouse Anda arahkan pada peta.

../../_images/3_0231.png

Koordinat peta ini sama dengan tipe koordinat yang telah Anda pelajari ketika Anda belajar mengenai GPS. Status bar ini akan menunjukkan posisi lintang dan bujur dari kursor mouse Anda.

Mungkin hal ini masih belum terlalu jelas untuk Anda, tapi seiring dengan meningkatnya kemampuan SIG Anda, hal ini nantinya akan terlihat masuk akal.

3.4 Menambah Layer Vektor

Sekarang kita akan menambahkan layer tambahan yang terdiri dari jaringan jalan ke dalam proyek kita.

  1. Klik pada tombol Tambahkan Layer Vektor pada toolbar.

../../_images/3_0241.png
  1. Sebuah kotak dialog akan muncul. Klik tombol Navigasi.

../../_images/3_0251.png
  1. Pergilah menuju file QGIS for Disaster Management/Sleman/Jalan_Sleman_OSM.shp. Pilih file dan klik Open.

Catatan

Salah satu format file yang umum adalah shapefiles, dengan ekstensi file .shp. Shapefiles sering digunakan untuk menyimpan geodata, dan umumnya digunakan pada aplikasi SIG seperti QGIS.

  1. Anda sekarang dapat melihat layer baru pada map canvas dan di daftar layer. Layer baru tersebut muncul di atas layer kecamatan dan layer rel kereta api.

../../_images/3_0261.png

3.5 Tool-tool Dasar QGIS

Kita telah melihat pada toolbar QGIS dan melihat tool untuk membuka proyek dan menambahkan layer baru. Di bawah ini akan ditampilkan beberapa daftar tool yang sering digunakan. Silahkan jika Anda ingin mengeksplorasi tools tersebut. Hal ini bertujuan untuk membuat kita merasa familiar dan terbiasa dengan QGIS.

../../_images/3_0271.png Toggle Editing

Mengedit suatu fitur pada layer

../../_images/3_0281.png

Menggerakkan Peta

Menggeser peta ke lokasi yang kita inginkan

../../_images/3_0291.png

Perbesar

Perbesar peta

../../_images/3_0301.png

Perkecil

Perkecil peta

../../_images/3_0311.png

Perbesar keseluruhan

Perbesar agar semua layer tampak pada jendela peta

../../_images/3_0321.png

Buka Tabel Attribut

Membuka tabel atribut dari sebuah layer

../../_images/3_0331.png

Memilih satu fitur

Memilih fitur dari layer yang dipilih

3.7 Mengatur Plugin

QGIS mempunyai menu utama, dimana kita akan melanjutkan eksplorasi lebih jauh pada panduan ini, tapi pada QGIS juga memungkinkan penggunaan plugin tambahan, sehingga menambah fungsi dari perangkat lunak ini. Dan lagi, plugin ini tidak berbayar. Untuk menggunakannya, Anda hanya butuh terhubung dengan internet dan menginstallnya. Pertama-tama mendownload pluginnya kemudian mengaktifkannya. Beberapa plugin telah terdownload dan dapat digunakan, Anda dapat melihatnya dengan pergi ke Plugins ‣ Kelola dan Install Plugin.

../../_images/3_0351.png

Jendela ini menampilkan daftar plugin yang telah terdownload dan dapat diaktifkan. Untuk mengaktifkan sebuah plugin, centanglah kotak disampingnya pada menu ini. Untuk sekarang, mari kita biarkan dahulu plugin-plugin ini apa adanya. Kita akan mencoba mendownload dan mengaktifkan plugin baru di sesi berikutnya.

../../_images/3_0361.png

3.7.1 Instalasi Plugin

Terdapat lebih banyak lagi plugin, tetapi mereka harus didownload terlebih dahulu. Untuk mendownload sebuah plugin, pergilah ke tab Tidak terpasang. Tab ini akan menampilkan plugin yang tersedia di dalam repositori, dan Anda akan melihat daftar plugin yang dapat didownload.

../../_images/3_0371.png

Perlu diingat bahwa plugin yang telah didownload dapat diaktifkan atau dinon-aktifkan dari tab Terinstall. Jika belum terdownload, mendownload sebuah plugin dari tab Tidak terpasang akan secara otomatis mengaktifkan plugin tersebut.

3.7.2 Plugin OpenLayers

Plugin OpenLayer akan memperkenankan Anda untuk melihat berbagai variasi peta berbasis web sebagai sebuah layer di dalam QGIS. Ini artinya Anda dapat mengakses peta OSM, Google Maps, dan Bing Maps, dari QGIS. Ikutilah langkah ini dan kita akan memahami bagaimana cara kerjanya.

  1. Pergilah ke Plugins ‣ Kelola dan Install Plugins... dan klik pada tab Tidak terpasang. Ketik openlayers di dalam kotak pencarian.

../../_images/3_0381.png
  1. Pilih OpenLayers Plugin dari list yang tersedia dan klik Install plugin.

../../_images/3_0391.png

Mungkin akan membutuhkan beberapa menit untuk mendownload plugin.

../../_images/3_0401.png
  1. Ketika proses download selesai, klik OK.

../../_images/3_0411.png
  1. Sekarang plugin OpenLayers telah terinstal dan diaktifkan. Klik pada tab Terinstall untuk melihatnya di daftar plugin aktif. Klik Close jika anda sudah selesai.

../../_images/3_0421.png
  1. Plugin OpenLayers ini menyediakan menu yang memberikan fungsi ekstra. Pergi ke Web ‣ OpenLayers plugin untuk melihat berbagai layer peta yang dapat ditampilkan.

../../_images/3_0431.png
  1. Pergi ke Web ‣ OpenLayers plugin ‣ Bing Maps ‣ Bing Aerial. Sebuah layer baru bernama “Bing Aerial” akan ditambahkan di panel layer, dan citranya akan muncul di kanvas peta Anda. Jika layer tersebut berada di atas layer-layer Anda yang lain, drag layer Bing tersebut ke urutan paling bawah dari daftar layer.

../../_images/3_0441.png

Proyek Anda seharusnya sekarang terlihat seperti ini:

../../_images/3_0451.png

Jika Anda perhatikan, ada sesuatu yang salah dengan petanya. Dapatkah Anda menebak apa itu? Ketiga layer yang berada di atas layer Bing Aerial seharusnya terlihat di dalam peta.

  1. Untuk memperbaikinya, pergilah ke Tampilan ‣ Panel-panel, dan aktifkan panel Layer Order Panel.

../../_images/3_0461.png
  1. Kemudian, panel urutan layer akan muncul di sebelah panel Layer (1). Klik panel tersebut dan hilangkan tanda centang pada Kontrol urutan render untuk memperbaiki masalah (2).

../../_images/3_0471.png
  1. Kembali ke panel Layer. Peta Anda akan tampil dengan urutan yang benar. Semua layer yang berada di atas Bing Aerial akan terlihat di dalam kanvas peta seperti gambar di bawah.

../../_images/3_0481.png

Menambahkan sebuah layer seperi imagery dari Bing Aerial akan mengubah Sistem Referensi Koordinat, atau CRS, proyek Anda. Artinya, proyek Anda tidak lagi menggunakan koordinat garis lintang dan bujur. Ini mungkin tidak banyak mempengaruhi projek Anda sekarang, tapi ini akan terasa nanti ketika kita mempelajari mengenai CRS.

  1. Jika data peta tidak sesuai dengan citra satelitnya, hal ini mungkin karena perbedaan CRS-nya. Anda dapat memperbaiki masalah ini dengan menuju ke Project ‣ Project Properties... dan periksalah kotak di sebelah Aktifkan transformasi CRS ‘on the fly’.

../../_images/3_0491.png ../../_images/3_050.png
  1. Sekarang kita bisa melihat data pada peta kita berada di atas citra satelit. Perhatikan bahwa citra ini merupakan citra yang sama yang disediakan oleh Bing Microsoft yang Anda tampilkan untuk mengedit data menggunakan JOSM. Cobalah untuk menghilangkan centang pada layer Kecamatan_Sleman sehingga Anda dapat melihat area dengan lebih baik. Perbesar tampilan untuk melihat detail citra dengan layer jaringan jalan dan jalur kereta ditampilkan di atas citra.

../../_images/3_051.png
  1. Hapuslah layer Bing Aerial dengan cara klik kanan pada layer tersebut dan pilih Buang.

  2. Cobalah terapkan untuk layer-layer lainnya yang memungkinkan di menu Web ‣ OpenLayers plugin.

3.7.3 Instalasi Plugin QGIS

Sekarang kita akan menginstal plugin InaSAFE.

  1. Pergi ke menu Plugins > Kelola dan Install Plugin.

../../_images/3_052.png
  1. Arahkan ke kotak pencarian dan ketikkan “inasafe”

../../_images/3_053.png
  1. Pilih InaSAFE dan klik Install plugin dan tunggu hingga muncul pemberitahuan yang menunjukkan bahwa plugin sudah terinstal dengan sukses.

../../_images/3_054.png
  1. Tutup jendela pengaturan plugin dan kita akan belajar tentang InaSAFE pada bab selanjutnya, Bab 8.

Sekarang Anda sudah mengetahui dasar QGIS mulai dari cara menginstal, memahami layout QGIS, mempelajari toolbar penting dan operasi dasar pada QGIS. Anda juga sudah belajar begaimana menginstal InaSAFE, sebuah plugin yang akan kita pelajari lebih lanjut pada bab terakhir dari modul ini.

Pergi ke bab selanjutnya –>